升级sass:Node Sass version 7.0.0 is incompatible with ^4.0.0 || ^5.0.0 || ^6.0.0

React 中使用sass,install时报错:

Node Sass version 7.0.0 is incompatible with ^4.0.0 || ^5.0.0 || ^6.0.0

node-sass已经废弃,升级到sass。

升级sass

升级sass,先卸载node sass。

yarn卸载node sass

yarn remove node-sass

npm 卸载node sass

npm uninstall node-sass

安装sass

yarn安装sass

yarn add -D sass

npm安装sass

npm i -D sass

版权声明:著作权归作者所有。

相关推荐

Angular 5升级到Angular 6

Angular升级建议先到https://update.angular.io,它会根据你选择的原Angular和目标Angular版本给出一些升级建议。Angular 5升级到Angular 6升级前1、如果项目中有用到HttpModule和Http Service,把它们切换到HttpClientModule和HttpClient Service。HttpClient有几个特性:不需要调用.js

Red Hat/CentOS的Nginx升级

在Linux系统,尽量不需要使用源码编译来安装软件,这样容易和系统的包管理混淆。此次升级是nginx1.0.15升级到nginx1.12.1升级前查看nginx版本$ nginx -v nginx version: nginx/1.0.15 查看系统版本# lsb_release -a LSB Version:  :base-4