vscode启动Dart DevTools报错,Failed to start DevTools: Dart DevTools exited with code 255

再vscode启动Flutter,Flutter版本是2.5.3,DevTools版本是2.9.2,报启动Dart DevTools失败:

Failed to start DevTools: Dart DevTools exited with code 255

Source: Dart(Extension)

查了相关资料,原因是devtools 2.9.2版本有问题。有些伙伴是降级到2.8.2解决的。

vscode

dart pub global activate devtools -v 2.8.0

Android Studio

1、关闭Android Studio

2、运行

dart pub global activate devtools -v 2.8.0

3、重新打开Android Studio,然后重新构建

参考:https://github.com/flutter/devtools/issues/3549

 

版权声明:著作权归作者所有。

相关推荐

CentOS7启动及排错

UEFi或BIOS初始化,运行POST开机自检 选择启动设备 引导装载程序, centos7是grub2 加载装载程序的配置文件:/etc/grub.d//etc/default/grub/boot/grub2/grub.cfg 加载initramfs驱动模块加载内核选项 内核初始化,centos7使用systemd代替init 执行initrd.target所有

Javascript检测开发者工具Devtools是否打开(Chrome/Firefox/IE)

首先要确定一点:是没有统一标准的方法来检测各个浏览器的devtools是否打开。所以只能针对不同的浏览器使用不同的方案,当然随着浏览器能的升级,有可能目前的方案也是会不适用的。这里列出目前各个浏览器可用的方案。方案一console.log隐式调用元素的idfunction isDevToolsOpened() {  var opened = fal